New Hardened-PHP

A new release of hardened-php is available. For those that don’t know, hardened-php is “a group of people creating a patchset that adds security hardening features to PHP to protect your servers on the one hand against a number of well known problems in hastily written PHP scripts and on the other hand against potential unknown vulnerabilities within the engine itself”.

The current version, 0.2.7, emerged about 4 months after 0.2.6. The release of PHP 4.3.11 and 5.0.4 was probably the cause for the new hardened-php release. The patch doesn’t seem to affect WordPress adversely either, or any other script for that matter.