Posted In Internet

Horrible Lag is Gone

This site had been experiencing horrible lag over the last few days. I sat down lastnight and got it all figured out. First, I thought it must somehow be related to the new apache httpd server I installed, not the case. After determining that it wasn’t an apache config problem or something, I started into WordPress. The lag didn’t come from WordPress itself, but a plugin I was using. Said plugin was wp-shortstat.

After disabling wp-shortstat, the page loads much quicker without the lag when loading the end of the page. It’s almost like my web server would get to the bottom of the page and then just stop sending the rest of the data to the browser. The browser would get to the very end of the page and just stop loading. If I’d view the rendered HTML in IE or FireFox, the the trailing “body” and “html” tags would be missing. It’s all better now though.

I also downloaded Flock lastnight at home. It’s pretty interesting, all sorts of feature for blogs and other services like Flock is built on FireFox 1.0. And if you’d like a blog, download flock and you can get one without an invite (H/T IO ERROR).

Well, now what?

Work with Me

I'm available for hire and always taking new clients, big and small. Got a project or an idea you'd like to discuss? Startup plan but no developer to make it happen? Just get in touch, I'd love to see if I can help you out!

Leave some Feedback

Got a question or some updated information releavant to this post? Please, leave a comment! The comments are a great way to get help, I read them all and reply to nearly every comment. Let's talk. :) is proudly hosted by DigitalOcean

About these ads