Posted In WordPress

Fix StanleyWP WordPress Theme Portfolio Grid

Fix display of portfolio grid rows

Back in September of 2014 I wrote about using the StanleyWP WordPress theme for a portfolio site. After I added some projects, I noticed the grid on the Portfolio page template wasn’t displaying rows correctly. I even noted it in my original post, towards the end.

I’ve had a few people contact me about how to fix the StanleyWP portfolio grid issue, and earlier today Arun left a comment asking how to fix the grid issue.

You need to be using a child theme for this, it’s just good practice. If you don’t know how to create a child theme, read my post on creating a child theme. It’s really easy to do, but may require you to reset your menu or some widgets after changing to the child theme.

Anyway, Arun confirmed that this gist fixed the problem for him:

Just save that code as template-portfolio.php and put it in your child theme directory. Your portfolio should now show three projects per row. No CSS or anything else needs to be modified, just that one page template.

Let me know if you have any issues or questions.

Well, now what?

Work with Me

I'm available for hire and always taking new clients, big and small. Got a project or an idea you'd like to discuss? Startup plan but no developer to make it happen? Just get in touch, I'd love to see if I can help you out!

Leave some Feedback

Got a question or some updated information releavant to this post? Please, leave a comment! The comments are a great way to get help, I read them all and reply to nearly every comment. Let's talk. :)

Longren.io is proudly hosted by DigitalOcean

About these ads
  • Vincent


    I think I don’t understand how do that, I download your child theme and put the template-portfolio in but nothing.


    • Did you make sure to select the “Portfolio” template on the page you were editing?

      • Vincent


        • Can you create an account on your site for me so I can have a look? Can delete it right after I’m done.

          • Vincent

            I send you a message 😉

  • Ali Stewart

    Hi Tyler, I was wondering if you know how to alter the colour of the the hover.zoom.js effect. I’ve tried editing the colour in this file, and tried adding my css but to no avail. I can see that the class .zoom green is also effecting this element but I’m not sure where this is. Can you possibly advise? Many thanks.

  • Hi Mr. Tyler, Can you help me to fix this problem?
    1. How can I set the title under the gravater/my image ?
    2. How the set up of “Homepage” with “portfolio” and “about” ?
    please help me. my web link: http://www.mdsuman.com

    • 1. Go to theme options, and then Homepage, make sure the Page Content and Portfolio widgets are enabled on the homepage.

      2. For your homepage, make sure you’ve selected the “Homepage” template.

      3. Set a featured image for your homepage (the image of yourself).

      4. Enter content on your homepage as you normally would, it’ll all show under the featured image. Below is how I have the top of my homepage content setup:

      Hi there, I'm Tyler Longren!

      The Full-Service, Always Available Iowa Freelance Web Developer Who Completes Projects Quickly And To Specification

  • Danilo Cardoso

    Hello , Tyler Longren .
    I am Brazilian.

    I loaded the model- portfolio.php in stanleywp – child directory , but nothing changed.
    Would you help me?

  • so simple theme, when it the latest update ? its compatible on 4.2 wp ?

  • Zach Keepers

    Hey Tyler! I can’t seem to get the portfolio grid to show up AT ALL. I know I must be missing something simple, but I don’t know what it is! Can you help me out?

    Website: jillandzach.com

  • javi

    Hi Tyler,
    I’ve set up my contact page but have no idea where the emails are being forwarded to but most importantly where do I go in order to set the desired forwarding email?
    thanks so much

  • SVG

    Hi Tyler,

    Thanks so much for showing how to fix the portfolio grid! I tried and it is working: when I open my website, I see a static homepage with the images and their project titles. So far so good. But when I have a look around on my website and return to the homepage by clicking on my logo in the upper left corner, the portfolio images are not showing anymore. Only the project titles appear, but I can not select any of them. Only if I refresh the website with the F5-button (in Google Chrome), the images reappear. In Internet Explorer even that won’t help, the images are not showing anymore. The same happens when I type the web address directly into my browser: sometimes none of the images appear, sometimes only a few of them show up. It looks like it happens quite randomly and makes my website highly unreliable. Is it a browser’s cache problem, or a bug in the StanleyWP theme, or something else…? Do you know how to fix this?

  • Tushar h

    Hi Tyler, How do I add NEXT and PREVIOUS links in PORTFOLIO